Wednesday 1 August 2012

Converging 10GbE and 1GbE networks with Force 10 and Dell PowerConnect

Customers are now moving from 1GbE iSCSI storage to 10GbE. This introduces a new challenge of converging 1 and 10 networks.  In this situation the customer has two existing EqualLogic 1GbE Arrays connected to a pair of Dell PowerConnect 5424 switches, these switches where joined together via a 2Gb LAG. The customer has purchased two new 10Gb Arrays and a pair of Dell Force 10 s4810 switches, but needs to have a period where the existing ESXi servers need to continue accessing the array.

The end solution:




Parts required:

4 x PowerConnect SFP Transceivers, Dell part number 0HHM9W
4 x Force10 SFP Transceivers, Dell part number 0GF76J
4 x LC-LC Multi-mode Optical Cables, depicted in blue above.

Twin-axe cables from the s4810 ports to the SFP combo ports do not work!! The answer is to use a Or if you are using PowerConnect 62xx series you need to use:

1 x Dell PowerConnect 622xx/M6220 Dual Port SFP+ module, Dell Part number 409-10135
2x 10GbE SFP+ Direct Attach copper cable 5M-KIT (Either or) Dell Part number 470-12823
2x 10GbE SFP+ Direct Attach copper cable 2M-KIT (Either or) Dell Part number 470-12822

Configuration on both PowerConnect switches:

Break the 2 port LAG between the PowerConnects, insert the SFP modules into to SFP ports 23 and 24 making sure the shared Ethernet ports aren't in use!

#conf
(config)#interface port-channel 1
(config)#desc Force10-link
(config)#port jumbo-frame
(config)#flowcontrol on
(config)#switchport mode trunk
(config)#switchport trunk allowed vlan add 100 (the iSCSI vlan)
#exit

#conf
(config)#internet range ethernet g23-24
(config)#channel-group 1 mode on (Must be ON not auto/active)

On the Force10 switches, update the firmware, stack the switches and issue these commands to create two port channels, two are required because the PowerConnect 5424's can't be stacked:

interface Port-channel 1
 description "LAG to bottom 5424"
 no ip address
 mtu 12000
 switchport
 channel-member TenGigabitEthernet 0/46
 channel-member TenGigabitEthernet 1/46
 no shutdown
interface Port-channel 2
 description "LAG to top 5424"
 no ip address
 mtu 12000
 switchport
 channel-member TenGigabitEthernet 0/47
 channel-member TenGigabitEthernet 1/47
 no shutdown

Now that the LAG between the 5424 switches and the F10's has been created we need to tell the VLANs that the traffic can pass across the LAG. The Force 10 was configured with two VLANs to match the 5424's, vlan 100 for iSCSI and vlan 101 for vMotion. The lines in bold are in important ones.

interface Vlan 100
 description iSCSI
 name iSCSI
 ip address 192.168.10.251/24
 tagged Port-channel 1-2
 untagged TenGigabitEthernet 0/0-23 (top switch)
 untagged TenGigabitEthernet 1/0-23 (bottom switch)
 no shutdown
interface Vlan 101
 description vMotion
 name vMotion
 ip address 192.168.11.251/24
 tagged Port-channel 1-2
 untagged TenGigabitEthernet 0/24-31
 untagged TenGigabitEthernet 1/24-31
 no shutdown
!

Test the LAG by pinging IP addresses on both sets of switches. Don't forget to copy the running-config to startup-config on all the switches. As a note the LAG did not work the first time , I had to remove the channel members with these commands:

no channel-member TenGigabitEthernet 0/46
no channel-member TenGigabitEthernet 0/47
no channel-member TenGigabitEthernet 1/46
no channel-member TenGigabitEthernet 1/47
Once I re-added the ports back the LAG sprang into life! Dell tech said they had seen this before!


No comments:

Post a Comment